
Digital Documentation 

Important features from each menu bar 

File Edit View Insert 

New Cut/Copy/Paste Toolbars Page Break 
Open Find, Find & Replace Sidebar Image/Chart/Media/Shape 
Templates Track Changes  Comment 
Export   Hyperlink 
Save/Save As   TOC and Index 
   Header and Footer 
   Page number 
   Special Character 

Format Styles Tables Tools 

Anchor Headings/Characters/Lists Insert Table Spelling 
Arrange Edit Style Insert Thesaurus 
Wrap Update Selected Style Delete Mail Merge Wizard 
Align New Style from Selection Select Protect 
Character/Paragraph Load Styles from Template Merge Cells Macros 
Page Style Manage Styles Split Cells  

 

Style Categories – Page, Paragraph, Character, Frame, List, Table 
Accessing Styles 

1. Style option from menu bar 
2. From Toolbar 
3. Using Sidebar, by clicking on Styles Icon (BEST way, EASIEST) 
4. Shortcut – F11

Feature Steps 

Applying Styles Select Text → Styles sidebar → Click on desired style to apply 
Fill Format Syles sidebar → Select desired style → Fill Format (bucket-like icon) 
 
Creating a Style 

Format the document → Styles sidebar → Choose style category → Styles Action → New Style 
from Selection → Dialog box → Name → OK                                                                      (from selection) 
Format the text → Styles sidebar → Choose category → Drag the selected portion to the Style 
menu                                                                                                                                             (using drag and drop) 

Updating a Style Format the text → Styles sidebar → Styles Action → Update Selected Style 
Load Styles Styles sidebar → Styles Action → Load Styles → dialog box → Choose category → Select template 

to copy styles from → Select the styles to be copied → OK 

  
 
 
Insert image 

Document → Cursor where image is to be inserted → Insert > Image → Choose file → Open 
Open file browser window (Win + E) → Select image → Drag to the document → Drop at the 
desired location 
Select image → Copy (Ctrl + C) → Paste on desired location (Ctrl + V) 
Insert > Image → Choose file → Check Insert as Link option → Open 

Modifying Image View>Toolbars>Image → Click on the desired tool to apply 

Resizing Image Select image → 8 sizing handles → Drag and resize 

Deleting image Select image → Press Delete key on keyboard 

  
Using Drawing Tools View>Toolbars>Drawing Toolbar → Select desired tool 
Changing properties 
of object 

Drawing Object Properties Toolbar → Choose property (icon) → Change value parameters 

Resizing Objects Select object → 8 resizing handles → Drag and resize 
Grouping Objects Hold Shift key and select objects → Format>Group>  Group/Ungroup/Enter Group/Exit Group 



Positioning Image In the Text 

1. Arrangement – position of image w.r.t other drawings/text  (Bring to Front, Send to Back, Forward One, Backward One, To Foreground, To Background)  
2. Anchoring – retain position to page/paragraph/character/frame 
3. Alignment – vertical/horizontal placement of image w.r.t its anchor 
4. Text Wrapping – placement of image w.r.t TEXT (Wrap off, Page Wrap, Optimal Page wrap, Wrap left, Wrap right, Wrap through)  

Filter 

1. Invert – Inverts colour values of image (inverts brightness if greyscale) 
2. Smooth – Softens the contrast 
3. Sharpen – Increases the contrast 
4. Remove Noise – Removes single pixels 
5. Solarisation – Reverses the tone (light → dark, dark → light) 
6. Aging – Stimulates the effect of time 
7. Posterise – Reduces colours, picture appears like a painting 
8. Charcoal Sketch – Changes image as charcoal sketch 
9. Relief – Adjusts light source to create shadow 
10. Mosaic – Joins group of pixels into a single area of one colour 

Advanced Features 

Feature Steps 

Hierarchy of Headings Enter text (H1-H10) → Styles sidebar → Headings → Apply heading style to each text 
Creating TOC Enter contents → Apply heading styles → Insert>Table of Contents and Index>Table of 

Contents, Index or Bibliography → dialog box → Change name (default Type tab) → OK 
Customising TOC Right click on TOC → Edit Index → dialog box → Tab (Type/Entries/Styles/Columns/Background) → Edit 

as desired → OK 
Updating TOC Right click on TOC → Update Index 
Deleting TOC Right click on TOC → Delete Index 

  
Checking Template File → Properties 

Creating a doc with 
templates 

File>New>Templates → selection window displayed → Select template → Click Open 

Creating Template Open document → File>Templates>Save → Templates dialog box → Name and category → 
Check Set as Default (optional) → Click Save 

Use In-built Templates Open doc → File>Templates>Manage Templates → dialog box → Select template → Click 
Open → Make changes → Save 

Online Templates File>Templates>Manage Templates → dialog box → Browse Online Templates icon (lower left corner) → official 
templates page of Libre gets opened → Download → Open Writer → File>Templates>Open 
Template… → Browse → Select file → Click Open 

Importing a Template File>Templates>Manage Templates → dialog box → Import Templates icon (bottom right corner) → Select Category/ Create 
New (check box →add name) → Click OK → ‘Open’ dialog box → Browse → Select file → Click Open  

Editing a Template File>Templates>Manage Templates → dialog box → Right click on the template to be edited → Select Edit → Make changes → Save 

Exporting a Template File>Templates>Manage Templates → dialog box → Select template to be exported → Click Export → Select Path 
dialog box → Choose location → Click OK 

Applying Templates to 
a Blank Doc 

Open document → Open desired Template → Ctrl + A & Ctrl + C (select all contents of template and copy) → Ctrl + V 
(Paste on the document) 

Components of Track Changes Toolbar 

1. View Track Changes 
2. Record Track Changes 
3. Previous Track Changes /Next Track Changes 
4. Accept/Accept All Track Changes 

 

5. Reject/Reject All Track Changes 
6. Manage Track Changes 
7. Insert Comment 

 



 

Feature Steps 
Protecting  Edit>Track Changes>Protect → Enter Password dialog box → Type password (Password & Confirm 

text boxes) → Click OK 
Recording Changes Edit>Track Changes>Record               (same thing for all other components) 

Accepting/Rejecting Click on the change made → Select Accept Track Change/Reject Track Change 
Manage Track Changes Edit>Track Changes>Manage… → dialog box → contains details and options to accept and reject 

Adding Comments Toolbar (View>Toolbars>Track Changes) → Insert Comment button → Comment box inserted (right side, 

includes details like writer’s name, date, time) → Type comment → Click anywhere on the doc to activate  
Deleting Comments Bottom right arrow on the comment box → Click Delete Comment 
Comparing Documents Edit>Track Changes> Compare Documents → Compare To dialog box → Browse and select 

original file to be compared → Manage Changes dialog box → perform action (accept/reject) → Close 
dialog box → Save 

Group – Different shapes behave as the same entity; change applied on one works on all 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Collection of all formatting informationStyle

•Effective repeated formatting
•Avoid inconsistency
•Reduce time and effort
•Improved content of document, not just appearence

Applying same style at many places scattered across the documentFill Format

•Convenient way to apply styles across mulitple locations
•Reduces manual effort and time

Representation of image in a finite set of digital values from 0 to 1Digital image/Picture

•Easier to understand
•Visual appeal

The reference of image is stored as a linkImage as Link

•Good for multiple copies of the same image
•Reduces the suze of the document

Feature to insert an automated table of contents/indexTable of Contents

1.Enteries taken from headings and sub-headings hyperlinked
2.Navigation is easier
3.Tab types - Type, Entries, Styles, Columns, Background

Preset layout that helps to create professional/formal documents easilyTemplates

•Reduces the need to copy specific content in multiple documents
•Contains all features that a regular document does, but these are DEFINED.
•Same content segregation, formatting features and appearance. 

Record of all changes made in a documentTrack Changes

1.Easier commenting, editing, reviewing among multiple users
2.Changes can be accepted or rejected by the original author
3.Reviewers can add comments (different coloured boxes for comments if multiple users added them)



Electronic Spreadsheet  

Feature Steps 

Consolidate Sheet with Data → Data>Consolidate → Choose Function (SUM, MAX, etc.) → “Source data ranges” and 
“Copy results to” → Add ranges → Options (“Link to source data”) (optional) → OK 

Subtotals Sheet → Data>Subtotals → Choose column in Group by → Select column for Calculate Subtotals for 
→ Select function from Use functions → 2nd Group, 3rd Group tabs for more groups and repeat (optional) → OK 

What-if 
Scenarios 

Select cells → Tools>Scenarios → Name the scenario → OK 

What-if 
Analysis 

Create input data → Write formulas for output data → Data>Multiple Operations → Enter cell ranges 
for Formulae, Row Input Cell, Column Input Cell → OK 

Goal Seek Write formula in a cell → Tools>Goal Seek → Add Formula Cell, Variable Value and Target Value → OK 

 

Enable Macro Recording – Tools>Options>LibreOffice>Advanced → Optional Features → Check “Enable macro 
recording” 

Feature Steps 

Recording 
& Saving a 

Macro 

Tools>Macros → Record Macro → Actions will be recorded → Stop Recording button → Basic Macros 
dialog box → Choose location from Save Macro to list box (Library and Module) → Click Save 

Running a 
Macro 

Tools>Macros>Run Macro → Macro Selector dialog box → Select library and module of macro’s 
location → Select the Macro (Macro name list) → Click Run 

Organising 
a Macro 

Tools>Macros>Organise Macros> LibreOffice Basic → Basic Macro dialog window → Click 
Organiser… → Basic Macro Organiser dialog box → Create a library (steps below)  or Select one→ 
Select/Create a Module → The macro gets stored and can be run anytime 

Creating a 
Library 

&Module 

Basic Macro Organiser dialog box → Libraries > New  
Basic Macro Organiser dialog box → Modules Tab > New 

 

SHEETS 

Feature Steps 

New Sheet Plus (+) icon located on the bottom left of the spreadsheet 
Or Right-click on the existing sheet tab → Select Insert Sheet from the drop down 
Or Sheet > Insert Sheet → Dialog box appears → Choose New → Specify position, number and name. 

Reference 
to other 
sheets 

Using Mouse -  Select the cell where you want the result  → Click = on the formula bar to start formula → 
Click on the sheet tab that contains the required data → Click on the cell you want to reference → Press Enter 
 
Using Keyboard - Select the cell where you want the result  → Type = to begin the formula →  Type $ sign →  Type 

the sheet name inside single quotes (' ')Use single quotes especially if the sheet name contains spaces → Type a dot . after 
the sheet name → Type the required cell address → Press Enter 
 

Reference 
to other 

docs. 

Using Mouse - Select the cell  → Click = on the formula bar → Switch to the other spreadsheet file → Click on 
the required sheet tab → Select the required cell or cell range → Press Enter 
 
Using Keyboard - Select the cell → Type = on formula bar→ Type the file path inside single quotes ' ' → Type 
# → Type $ → Type the sheet name → Type . → Type the required cell address or range → Press Enter  
 

  
Inserting a 
Sheet from 

Another File 
 

Open the current spreadsheet → Go to Sheet menu → Click Insert Sheet → Select From File → Click 
Browse → Select the required file → Select the required sheet from the list → Check the Link checkbox 
to ensure changes are reflected → Click OK 
 

Updating 
Data 

Tools > Options > LibreOffice Calc > General > Updating 

 



HYPERLINKS 

Feature Steps 

Creating 
Hyperlink 

Open the required spreadsheet → Insert > Hyperlink → In the Hyperlink dialog box, click Document (left 
pane) → Click the button next to Path → Select the required spreadsheet document → Click Target → 
Select the required sheet → Click Apply and Close → Enter the desired text in the Text box → Click Apply 
and OK 

Opening 
Hyperlink 

Press and hold Ctrl key → Click on the hyperlinked text 

Editing 
Hyperlink 

Place the cursor on the hyperlink → Right-click → Click Edit Hyperlink → Make required changes in the 
Hyperlink dialog box → Click OK 

Removing 
Hyperlink 

Right-click on the hyperlink → Click Remove Hyperlink 

Linking to 
External 

Data 

Open the spreadsheet → Select the cell where external data is to be inserted → Go to Sheet > Link to 
External Data → Enter the URL in the dialog box → Press Enter → Select the required language option → 
Click OK 

Linking to 
Registered 

Data 

Go to Tools > Options > LibreOffice Base > Databases → dialog box appears Click New → In the Create Database 
Link dialog box, select the required database file (Browse it needed) → Click OK 
 

 

SHARING AND REVIEWING 

Feature Steps 

Sharing a 
Spreadsheet 

Save a spreadsheet → Go to Tools > Share Spreadsheet → Share Document dialog box 
appears → Check “Share this spreadsheet with other users” → Click OK → Confirmation dialog 
box appears → Click Yes → Spreadsheet name displays (shared) in title bar 

Opening a Shared 
Spreadsheet 

Open the shared spreadsheet → Warning message appears → (Optional) Check “Do not show 
warning again” → Click OK → Spreadsheet opens in shared mode 

Saving a Shared 
Spreadsheet 

Make changes in the shared spreadsheet → Save the spreadsheet → If no conflict among multiple 

users, confirmation message appears → If conflict occurs, Resolve Conflict dialog box appears → 
Resolve conflicts only one user can, the others will be locked from that→ Save the spreadsheet 

Disabling Shared 
Mode  

Open the spreadsheet → Go to Tools > Share Spreadsheet → Share Document dialog box 
appears → Uncheck “Share this spreadsheet with other users” → Click OK → Confirmation 
dialog box appears → Click Yes → “(shared)” disappears from title bar 

Recording Changes Ensure shared mode is disabled → Go to Edit > Track Changes > Record → Make required 
changes in the spreadsheet → Modified cells are highlighted → Move cursor over changed cell 
to view change details 

Adding Comments  Go to Edit > Track Changes > Comment → Add Comment window appears → Enter comment 
→ Click on the cell to view the comment 

Inserting Comment  Select the cell → Go to Insert > Comment → Comment box appears → Type the comment → 
Right-click the cell to manage comment 

Edit / Delete / Show 
/ Hide Comment 

Right-click the cell containing comment → Select Edit Comment/Delete Comment/Show 
Comment/Hide Comment 

Formatting 
Comment 

Right-click the cell containing comment → Select Format Cell → Format Cells dialog box 
appears → Apply required formatting options (Font, Effects, Alignment, Borders, Background, 
Cell Protection) → Click OK 

Reviewing Changes 
– Show Changes 

Go to Edit > Track Changes > Show → Show Changes dialog window appears → Select 
required options → Click OK 

Reviewing Changes 
– Accept / Reject 

Go to Edit > Track Changes > Manage → Manage Changes dialog window appears → Select 
change entry → Click Accept / Accept All / Reject / Reject All → Click Close 



Merging Two Files Open the original spreadsheet → Go to Edit > Track Changes > Merge Document → Merge 
With dialog window appears → Select the second spreadsheet file → Click Open → Manage 
Changes dialog window appears → Click Accept All → Save the spreadsheet 

Comparing Two 
Documents 

Open the original spreadsheet → Go to Edit > Track Changes > Compare Document → 
Compare To dialog window appears → Select the second spreadsheet file → Click Open → 
Manage Changes dialog window appears → Click Accept / Reject as required → Click Close 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

•Combine information from multiple sheets of the spreadsheet into one place to summarize the information
•It is used to view and compare variety of data in a single spreadsheet for identifying trends and relationships.

Consolidate

•Subtotals - Group data automatically to apply common functions like sum, average, etc. on it.
•Group and Outline - Create an outline of the selected data and can group rows and columns together so that 

one can collapse (-) to hide it or expand (+) it. 

Groups and Subtotal

•A set of values that can be used within the calculations in the spreadsheet.
•It is used to explore and compare various alternatives depending on the changing conditions.
•It is used in the beginning of any project to optimize the output.
•It can predict the output and one can make the best plan of action by trying various inputs.

What-if Scenarios

•Planning tool for what-if questions
•It has two arrays of cells - one for input values and the other for the formula to display result
•It us useful to check the output at the beginning to understand the efficiency of the analysis.
•Example of its usage - When we want to know how much profit we earn for a particular product, for a series of 

selling units.

What-if Analysis Tool

•The previous tools were used to obtain the desired output.
•Goal seek is used to find out the input for a specific output.
•For example - If you want to how many more marks need to achieve to get your target percentage of 95%, you 

can use goal seek.

Goal Seek

•Macros are a set of stored functions used to automate processes repeatedly. It is a single instruction that 
executes a set of instructions.

•They are used to perform most of the redundant tasks with relative ease.
•Macros can save us the effort of remembering and typing the formulas for calculations if they are used as a 

function.
• Instead of using Sub and End Sub (which help in doing a particular action like formatting, etc.), use Function 

and End Function (which helps in returning a value by accepting arguments/values, and performing 
calculations)

Macros

•They are useful to jump to a document stored at a different location from within a document. It can be used to 
jump from a sheet in the same spreadsheet, different spreadsheet or a website.

•Absolute hyperlink - Stores complete location where a file is stored and it won't work if the file is removed 
from that location.

•Relative hyperlink - Stores the location with respect to current location. If the complete folder containing 
active spreadsheet is moved, the relative link will still be accessible as it is bound to the source folder where 
the active spreadsheet is stored.

Hyperlinks

•Can be used by multiple users at a time
•Users can make changes simultaneously
•It saves the trouble of keeping track of multiple copies of the same spreadsheet
•It allows working in collaboration so that everyone can contibute, make changes, and view it.

Shared spreadsheet



Database Management System 

Advantages of DBMS 

1. The data is stored in an organized manner. 
2. It allows analysis of data based on criteria. 
3. It allows sharing of data. 
4. It reduces the need to repeat data (Data Redundancy) 
5. Inconsistency of the data is reduced. 
6. It offers increased efficiency, accuracy, and validity. 
7. It provides security and encryption by setting passwords or translating data. 

 

Data and Information 

• Data – The raw facts about any person, place, activity, or things.  
Examples – marks, weights, prices, costs, names, etc. 

• Information – The processed or organized form of data.  
Examples – pay-slips, schedules, worksheet, bar charts, invoices, account returns, etc. 

• Comparison - Marks obtained by the students are data, the report card/marksheet is the information.  
The temperature recorded is the data which can be processed to find out the maximum or minimum temperature 
of day and night. 

Database and Database Management System (DBMS)  

• Objective - The ease of entering data, its efficient storage, accuracy and fast retrieval. 
• Computerized databases are used to store, manipulate, and manage the database. Examples – booking railway 

tickets, search for a book in library, get salary details, get the balance amount after withdrawal from ATM, etc.  
• A database is a collection of logically related data items stored in an organized manner.  
• The information can be added, modified, deleted, or displayed. 
• The software used to create, update, and retrieve data is known as the database management system. It 

facilitates planning and maintenance of a database for the user. 
• Common DBMS – OpenOffice Base, LibreOffice Base, Oracle, Ingress, MySQL, etc. 

 

Data Models 

A data model is the structure of a database that describes the manner in which data will be stored and retrieved, 
depending on the data being stored.  

Types: 

1. Hierarchical Data Model – stores data in a tree-like structure if the form of records. All these records are linked to 
each other at various levels, forming a hierarchy.  

2. Network Data Model – multiple records are linked to the same master file, making an inverted tree structure 
3. Relational Data Model – most common, proposed in 1970 by E.F. Codd. It is based on the principle of setting 

relationships between two or more tables of the same database.  

 

Terminology 

1. Entity – A real world object about which the 
information is to be stored. 

2. Attributes – The details associated with the 
entity 

3. Table – A collection of logically related records 
organised in the form of rows and columns 

4. Field – The smallest entity of a database. They are 
individual record characteristics. 

5. Data values – Raw data represented in numeric, 
character, or any other form. 

6. Record or row – The data values for all the fields 
is collectively called a record.  

7. Primary Key – A field that uniquely identifies a 
row in a table.  



8. Composite Key – Usage of more than one fields 
to identify a record 

9. Foreign Key – The field of one table that is used 
to uniquely identify records of another table. It 
builds a relation between two tables 

10. Candidate Key – The field values that are eligible 
to be the primary key 

11. Alternate Key – Out of the candidate keys, only 
one or two are made primary keys. The others are 
alternate keys. 

 

Objects of RDBMS  

1. Tables – Basic unit of DBMS that stores data in 
rows and columns. 

2. Forms – Used to enter data in an easy and user-
friendly manner (with text boxes, labels, lists, 
checkboxes, etc.) 

3. Queries – Used to retrieve the desired 
information by asking questions 

4. Reports – The output of a query is displayed in a 
proper layout. 

Data Types 

1. Text 
2. Numeric 
3. Currency 
4. Date 
5. Boolean 
6. Binary 

 

Feature Steps 

Creating a New 
Database 

Open LibreOffice Base → Database Wizard opens → Click Create a New Database → Click Next → 
Select radio button with option ‘No, do not register the database’ → Select ‘open a database for 
editing’ or ‘create tables using wizard’ → Click Finish → Save As dialog box appears → Choose 
location, name the file and save (.odb extension) 

Opening a 
Database 

File>Open → ‘Open’ dialog box → Browse for the file and select the desired one → Click Open 

Creating a Table 
Using Wizard 

Open LibreOffice Base → Database Wizard opens → Click Create a New Database → Click Next → Select radio button with option ‘No, do not register the 

database’ → Select ‘create tables using wizard’ → Click Finish OR from tasks pane, select that thing → Table wizard dialog box opens 
→ Select table from Sample tables list → Select required fields → Move fields from Available 
Fields to Selected Fields using > or >> → Click Next → Set field types and formats → Click Next → 
Set primary key → Click Next → Select desired option → Click Finish → Data Sheet View opens  

Creating a Table 
Using Design 

View 

In Database window click “Create Table in Design View” from Tasks Pane → Table Design window 
opens → Enter field name in Field Name column → Press Tab → Select data type from Field Type 
list → Set required properties in Field Properties pane → Press Tab → Enter description (optional) → 
Press Tab to move to next row → Repeat steps for all fields 

Setting Primary 
Key 

Right-click before the required field name → Select Primary Key → Key icon appears before the 
field name 

Saving a table Click Save button or go to File > Save As → Enter table name → Click OK → Close the table design 
window 

Opening Table / 
Entering Data 

Double-click the required table in Tables Object Area → OR Right-click the table and Click Open 
→ Datasheet view appears → Enter data in fields → Press Tab to move to next field → After 
completing a record, cursor moves to next record. 

Editing Data Open the table → Click on the field value to be edited → Enter new value → Save the table → Press 
Esc to cancel changes (if required) 

Deleting Records Open the table → Select the record → Press Del key   OR    Right-click the record → Click Delete 
Rows    OR    Go to Edit > Delete Record → Confirmation dialog appears → Click Yes to delete → 
Click No to cancel 

Renaming Table Right click on the table → Select Rename... → Type new name and press Enter  
Sorting Data 
(Single Field) 

Open the table in datasheet view → Select the field to sort → Click Sort Ascending icon or Sort 
Descending icon 

Sorting Data 
(Multiple Fields) 

Open the table → Click Sort icon on toolbar → Sort Order dialog box appears → Select required 
field(s) → Choose order (Ascending / Descending) → Click OK 

Closing 
LibreOffice Base 

Go to File > Close   OR   Click Close (X) button 

 

 



Relationships Between Tables 

• Relationships help to avoid redundancy and inconsistency of data. It ensures that no data is repeated and there 
are no different data values for a single entity.  

• Setting relationships require at least one common field and that field must have same data types among each 
table.  

• Master Table – The main table with required information about entities. (the record in it is the master record) 
• Transaction Table – It records the corresponding activities or events related to the entities in master table. Simple, 

it is the table with is related with the main table. (the record in it is the transaction record). 

Types of relationships 

1. One-to-One: One specific record of a master table has one and only one corresponding record in the transaction 
table. 

2. One-to-Many: One specific record of the master table has more than one corresponding records related in the 
transaction table. 

3. Many-to-Many: Multiple records in the master table correspond to multiple records in the transaction table. 

 

Advantages of Relating Tables 

1. Prevent data redundancy 
2. Prevent missing data by syncing deletions. (Referential integrity) 
3. Restricts the user from entering invalid data in the referenced fields. 
4. Any updates in master table are automatically reflected in the transaction tables. 

 

Referential Integrity 

According to this principle, no unmatched foreign key values should exist in the database. 

If a record is deleted in the master table, it must be deleted in the transaction table as well.  

Options to maintain integrity: 

1. No action – (default) User is not allowed to delete/update any record in master table if any related record exists in 
the transaction table 

2. Update cascade – Allows user to update/delete the referenced field but along with the related record in the 
transaction table. 

3. Set NULL – Assigns NULL value to all related fields if the master record is deleted/updated. 
4. Set default – Assigns any fixed default value to all related fields if the master record is deleted/updated. 

Feature Steps 

Setting 
Relationship 
Between Tables 

Go to Tools > Relationships → Relationship Design window appears → Add Tables dialog box 
appears → Select first table → Click Add → Select second table → Click Add → Click Close → Both 
tables appear in Relationship Area → Drag the common field from foreign key table → Drop it on 
the matching primary key field of the related table → Relationship line appears between the tables 

 

Queries  

Feature Steps  
Creating a Query 
Using Wizard 

Open Database → Click Queries icon → Click Use Wizard to Create Query → Select required table 
→ Move required fields using > button → Click Next → Set Sorting order (if required) → Click Next → 
Set Search Condition (Field, Condition, Value) → Click Next → Skip Summary steps (if not 
required) → Set Alias names (if required) → Click Next → Rename Query (if required) → Select 
Display Query option → Click Finish 

Creating a Query 
in Design View 

Click Queries icon → Click Create Query in Design View → Add required tables → Click Close → 
Add required fields to Design Grid → Set Alias names (if required) → Set Sorting order (if required) 
→ Set Criteria in Criterion row (if required) → Click Run (F5) → Click Save → Enter Query Name → 
Click OK 



Working with 
Numerical 
Functions in 
Query 

Open Query in Design View → Add required tables → Add required fields → In Function row select 
Group (for grouping field) → Select required function (Sum/Count/Average/Min/Max) for numeric 
field → Set Criterion (if required) → Press F5 to Run Query → Save Query 

Editing a Query Click Queries icon → Right click on Query Name → Select Edit → Make required changes in Design 
Grid (Fields/Sort/Criteria/Function) → Click Run (F5) → Click Save → Close Query Window 

 

Forms 

Feature Steps 
Creating a Form Using 

Wizard 
Open Database → Click Forms icon → Click Use Wizard to Create Form → Select 
required Table/Query → Move required fields using > button → Click Next → Skip Subform 
step (if not required) → Choose Layout (Columnar/Datasheet/Block) → Select 
Alignment → Click Next → Choose Data Entry option (Display/Enter/Both) → Click Next → 
Apply Style (Border/Background) → Click Next → Enter Form Name → Select Work with 
Form or Modify Form → Click Finish 

Modifying a Form Click Forms icon → Right click on Form Name → Select Edit → Form Design View opens 
→ Make required changes → Save Form 

Changing Background 
Color of Form 

Open Form in Design View → Right click on Form → Select Page Style → Open Area tab 
→ Choose Color → Click OK 

Editing Labels 
(Caption/Formatting) 

Open Form in Design View → Ctrl+Click on Label → Right click → Select Control 
Properties → Modify Label text / Font / Alignment / Size → Close Properties Dialog 

Moving a Control Open Form in Design View → Click on control (Label + Textbox selected) → Drag to 
desired position → Release mouse 

Resizing a Textbox 
Control 

Open Form in Design View → Ctrl+Click on Textbox → Drag position handlers to adjust 
size 

Adding a Tool Tip Open Form in Design View → Ctrl+Click on control → Right click → Select Control 
Properties → Enter text in Help Text property → Close Dialog 

Adding Calendar to Date 
Field 

Open Form in Design View → Ctrl+Click Date Field → Open Control Properties → Set 
Date Format → Set DropDown property to Yes → Close Dialog 

Adding a Label (Title/Text) 
to Form 

Open Form in Design View → Click Label tool from Form Controls toolbar → Drag to 
create label → Open Control Properties → Enter Label text → Set Font properties → Close 
Dialog 

Adding a New Record 
Using Form 

Open Form → Switch to Form View (Design Mode off) → Click New Record button → Enter 
data → Click Save Record button 

Deleting a Record Using 
Form 

Open Form in Form View → Navigate to required record → Click Delete button 

Switching Between 
Design View and Form 

View 

Click Design Mode button on Forms Controls toolbar to toggle views 

A control is any element of a form like textbox, checklist, etc. 

 

Reports 

Feature Steps 

Creating a Report 
Using Wizard 

Open Database → Click Reports icon → Click Use Wizard to Create Report → Select required 
Table/Query → Move required fields using >> button → Click Next → Modify Field Labels (if 
required) → Click Next → Set Grouping (if required) → Click Next → Set Sorting Field and Order 
(Ascending/Descending) → Click Next → Choose Layout (Tabular/Columnar etc.) → Select 
Header/Footer Layout → Choose Orientation (Portrait/Landscape) → Click Next → Enter Report 
Name → Select Dynamic or Static option → Choose Create Report or Modify Report → Click 
Finish 



Modifying a 
Report 

Click Reports icon → Right click Report Name → Select Edit → Report Builder window opens → 
Make required changes → Save Report 

Inserting 
Title/Heading  

Open Report in Edit Mode → Click Label tool from Report Controls toolbar → Drag to create label 
box → Open Properties → Enter Title text → Set Font style and size → Close Properties dialog 

Inserting Date 
and Time 

Open Report in Edit Mode → Click Page Header area → Click Insert menu → Select Date and Time 
→ Choose desired format → Click OK → Reposition date if required 

Creating 
Grouped Report 

Open Report Wizard → Select required fields → In Grouping step select field for grouping → 
Complete remaining steps → Click Finish 

 

Keyboard Shortcuts 

• Accessing styles – F11 
• Quit Fill Format/Cancel any drawing function – Esc 
• Opening File Browser window – Win + E 
• Copy – Ctrl + C 
• Paste – Ctrl + V 
• Link an image – drag and drop the image while holding Ctrl + Shift 
• Deleting – Delete key 
• Proportional resizing – Shift and then resize 
• Select multiple things – Shift and click all you want to select 
• Select All – Ctrl + A 
• Open hyperlink – Ctrl + Click 
• Templates window – Ctrl + Shift + N 
• Save – Ctrl + S 
• Open – Ctrl + O 
• New – Ctrl + N 
• Record changes – Ctrl + Shift + C 
• Edit Label – Ctrl + Click 


